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DISCUSSION & GUESTBOOK Interaction Management

SUMMARY

A discussion (also known as a forum) allows visitors to respond to statements and questions
from other visitors. It is also possible to start a new (sub)discussion yourself. Discussions can
be followed on the website and reactions can be added. The editor has the option of
moderating discussion reactions either before or after they are posted.

This functionality can also be set up as a guestbook which allows individual comments to be
posted instead of interactive discussions.
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1 CREATING A DISCUSSION

Using the Discussion content element, two types of discussions can be maintained: Forum and
Guestbook. The difference between the two is that in a forum you can comment on other visitorsd
comments and in a guestbook you cannot. Besides creating specific formats for discussions and
creating discussions based upon these formats, it is also possible to moderate discussions.

To place a discussion element on a page, a discussion model and a discussion name have to be
created first.

1.1 Discussion name

To create a new discussion, navigate to Maintain > Discussions > and click the
[Discussions] tab:

= Select O6New discussiond.

3 MyWeb - Discussions - Microsoft Internet Explorer

Maintain - Discussions

Discussion models Discussions Moderate

Select b Select = Select discussion %
Select discussion

|
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= Give the discussion a name.

= Selectd No &

next 0t ®edc@luseed he di scussion

2 MyWeb - Discussions - Microsoft Internet Explorer

Select

Basic settings

Moderation

Discussion models

Maintain - Discussions

Discussions Moderate
b Selact |New discussion V|
Discussion name: |Sp0rts |
Closed: Oives @ o
User groups:
Maone
add:
= Select &4

W

has

= If desired, limit the moderation of the discussion to specific user groups. These user
groups can be defined in the Configure
selected, any user authorized to do so (on the [Moderate]

this discussion.

> Authorization

menu. If no user group is
tab) is allowed to moderate
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1.2 Discussion model

A discussion model defines the general setup of a discussion. The general setup controls the
number of messages that are shown, whether a discussion can be moderated, and who can
participate in a discussion. To create a new discussion model, select the [Discussion models]

tab from the Maintain > Discussions

= Select O6New di scussion model 0.

2 MyWeb - Discussions - Microsoft Internet Explorer = || g
s
Maintain - Discussions —
Discussion models Discussions Moderate
Choose P Choose | = Choose discussion model
discussion = izhoose discussion model
rmodel i i

= Give the model a name (see A in the image below ).

2 MyWeb - Discussions - Microsoft Internet Explorer,

Maintain - Discussions —

Discussion models Discussions Moderate
Choose P Choose | yew discussion maodel v|
discussion
rnodel
Model Model name: o Sports |
Maderation: Post-moderated |+
Presentation: W Farum v

Maximum thread depth:

Mumber of threads to show at start:

Is published: Oives (Mo

Everyone rmay post: OYes @ND
Wha may post?: [

v

Close

= Determine whether the moderating should be performed before or after postings.

[ T | |
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= Select the desired appear anc e next t o By Rlefald,etheteais a ohoide.
between a forum and a guestbook.

= Determine the ©6Maxi (the totat nomberaofiresdoaspsttd bie displayed).
If this field is left blank, there is no limit.

= Determine the number of topics to be shownon t he page next to O&6Number of toh
show at Ifstheanurhb@r. of topics is higher than this value, numbered links to
subsequent pages containing the remaining topics appears on the website. The default

value is 2.

= When the model is ready for use, select6 Yesd next to O6ls published®

= Determine who is allowed to participate in the discussion. | f O6Nob6 is checked next t
6Everyone may post o, an additional field appears where

assigned. These groups can be defined on the [Web groups] tab from the Configure
> Web users menu. A visitor from another web user group may read the discussion but
is not allowed to participate.

[ | | | |
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2 PLACING A DISCUSSION ON A PAGE

To place the discussion element on a page, follow these steps:

= Add the discussion content element to a page: Insert > User interaction >
Discussion

= Select the name of the discussion model and discussion from the respective lists.

&% Discussion e BHE A
Discussion model: | Sparts model v|
Discussion name: | Sparts v|

The discussion is now open but empty on the website because there have not yet been any posts:

OPEN FOR BUSINESS

MyWeb > Content » Discussion
T

poll Discussion
» Discussion Title Author Date Posts

New topic

<GX> CREATIVE ONLINE DEVELOPMENT B.V. e-mail info@gx.nl | http://www.gx.nl/ ‘ 9/18 ‘




DISCUSSION & GUESTBOOK Interaction Management

When the visitor clicks [New topic] to the right of a new discussion, a new thread is started. A

new message form displays in which the visitor can create their new message. This will be a new
topic within the scope of the current discussion:

OPEN FOR BUSINESS

MyWeb Content Discussion

Pall Discussion

» Discussion

New message

Title

|Spons injuries |
Author

John Doe
Message

I've been a foothall A
coach for the past 15
years and in that time 3
I've noticed a dramatic
increase in the number v

L Send-message ]

When the visitor clicks [Send message], the message is added to the discussion, however, since
this is a pre-moderated discussion, the message will not appear for others to see until the
moderator has approved the message. If this had beena 6 P omd d e r adiseussidn, the message

would have been shown immediately. Moderators have the option of adjusting post-moderated
messages at a later time or deleting them altogether.
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3 MODERATING DISCUSSIONS

To moderate discussions, select the [Moderate] tab from the Maintain > Discussions
menu. From here you can adjust, close or delete threads and messages in order to keep
discussions up-to-date and manageable.

Discussion messages are either pre- or post-moderated. The advantage of pre-moderated
discussions is that you can control the text that is published and weed out postings containing
inappropriate language/content. Pre-moderated messages are only published after the moderator
has approved them. The disadvantage of pre-moderated messages is that there can be delays
between when a message is posted and when it appears on the website and this can tend to make
discussions less spontaneous. Post-moderated messages are typically more appropriate for
discussions that allow only registered users to participate.

3.1 Moderating a thread

Moderate a thread as follows:

1. The [Moderate] tab from Maintain > Discussions shows all the active discussions.
For example:

2 MyWeb - Discussions - Microsoft Internet Explorer,

Maintain - Discussions

Discussion models Discussions Moderate

Discussions ou can rioderate the follawing discussions:
State = Choose v

v

Apply | Close

| | |
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2. Select the discussion you want to moderate from the list (in this example we select the

06 S p o difcussdon):

| MyWeh - Discussions - Microsoft Internet Explorer

Maintain - Discussions

Discussion models Discussions Moderate
Discussions You can moderate the following discussions:
State | = Choose b
Sports
IMusg
Traw
Hobbies

W

After you select the discussion, an overview of the discussion and message threads

appears:

23 MyWeb - Discussions - Microsoft Internet Explorer

Maintain - Discussions

Discussion models Discussions Moderate

Discussion Discussion name Sports
Thread Sports injuries

Messages Message
This thread contain no messages,

Back Back to thread overview

Close Delete

s

3. Click the link for the discussion in the Discussion overview.
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A dialog box containing the message that need to be moderated appears:

2l MyWeb, - Discussions - Microsoft Internet Explorer

Maintain - Discussions

Discussion models Discussions Moderate

Discussion Discussion name Sports

Edit message State Mew and non-public s
Title Sports injuries

MESSA0E |1'ye heen a foothall coach far the past 15 years and in that time ['ve noticed a dramatic increase in the
number of injuries my players have sustained.

Back Back to messages averview

O08paertini-publc). state is
oi ntas anéw ssatelfact i ng OPul

I'n the case of tbisnmessagd) (
You have the option at this p
this message.

4, Sel ect O6Publicd6 to approve this messagesitamd to allo
or ORejectedodlItmotdi salelxawpilte. we select O6Publicd

Edit message State Mew and non-public

Title Mew and non-public

Message [0t Cred h for the past 15 years and in that time I've noticed a dramatic increase in the
nurmber of injuries my players have sustained,

|
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5. Cl iBack to discussions over vi eiscdssion Nomthedibteim you sel ect
this case 06Sportsd, the approved message now appears

3l MyWeb - Discussions - Microsoft Internet Explorer,

Maintain - Discussions

Discussion models Discussions Moderate
Discussion Discussion name Sports
Threads Thread Close Delete

Sports injuries

Back Back to discussions overview

Close

The thread is now visible on the website:

OPEN FOR BUSINESS

Myweb Content Discussion
Poll

Blscussion Title Author Date Posts
Sports injuries John Doe  21-01-2008 16:14 0

New topic

On the [Moderate] tab in the Edit environment, youcans el ect 0 Clloesteedd otro 6 De
close or delete the thread. A closed thread remains visible on the website, but

comments can no longer be posted. Deleting a thread erases the entire thread from GX

WebManager permanently, including all responses.
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3.2 Moderating a message

Moderate a message as follows:

1. The [Moderate] tab from Maintain > Discussions shows all the discussions:

2 MyWeb - Discussions - Microsoft Internet Explorer

Maintain - Discussions

Discussion models Discussions Moderate
Discussions You can moderate the following discussions:
Sports
Music
Travel
Hobhies

b

Close

2. Selectthedi scussion from the discussion list (in

2 MyWeb - Discussions - Microsoft Internet Explorer

Maintain - Discussions

Discussion models Discussions Moderate

Discussian Discussion name Sports

Threads Thread Close Delete

o 0O

Sports injuries

Back Back to discussions averview

T | |
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3. Select the relevant thoeadi i nuri leis dnteiseesampldh® sed $p
several messages have been added that need to be moderated.

3 MyWeb - Discussions - Microsoft Internet Explorer

Maintain - Discussions

Discussion models Discussions Moderate

Discussion Discussion name Sports

Threads Thread Close Delete
Proper use of equiprnent O il

Sports injuries 1 O
Training O il
0o o

wou're all stupid

Back Back to discussions overview
4, Click a message to view it and t opuwhilaingde tia sd6 Bubaltiec & r o
or Rejectedd. | n t his examplset,upd Wodu Shraes aallll the hall marks of

that is most likely inappropriate and needs to be rejected.

5. Click a message to view it. An overview of the message will appear that lists the
reactions that have been sent:

2 MyWeb - Discussions - Microsoft Internet Explorer,

Maintain - Discussions

Discussion models Discussions Moderate

Discussion Discussion name Sports
Thread You're all stupid

Messages Message Close Delete
This thread contain no messages.

Back Back to thread overview

Close
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Click the link for the message next to Thread to view the message:

EEX

Why don't you find something mare intersting to talk about

2 MyWeb - Discussions - Microsoft Internet Explorer
Maintain - Discussions
Discussion models Discussions Moderate
Discussion Discussion name Sports
Edit message State
Title You're all stupid
M&sS308 yhat & stupid and boring discussion this is.
like nude beaches or Kurt Cobain?
Back Back to messages overview

be changedt o

Since this message is not suitable for the forum, it is rejected. This message is now no

icd.in

t he

longer visible in the thread. However, it still exists in GX WebManager and its state could
OPubl i

T
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3.3 Presenting a discussion model

The [ Presentation ] tab in the Format > Presentation menu allows you to select a forum
or a guestbook for a discussion model. This allows you to control the look and feel of the
discussion.

= Navigate to the Format > Presentation and click the [Presentations] tab:

- Microsoft Internet Explorer

Format - Presentation

Presentations Presentation folders Page parts
Select 4 Scope Presentation
ForumSettings ~ | WM Forum v

Meta information name WM Forum
MHame WM Forum
Ranking

Default presentation is ®ves ONo
selectable
Meta information folder C:\GH\WebManager®twebmanageriywebappsibackendyWER-
INFyprojectsnl.gx. product.wmpeornmunityeditionstyledfarurmifarum Contraller xml

Location SWEB-INF/project/nl.ax product.wmpcommunityeditionstyleforumforumContraller jspf
Scope ForumSettings
Prewiew image

Froperties Name Description Datatype Default
even_color Achtergrondkleur even Color E3iiniid
odd_colar Achtergrondkleur oneven Caolor #eTebef
header_color Achtergrondkleur header Caolor #hac?cf
normal Mormalclass Font normal
header Headerclass Fant header
niormal Mormnalclass Font normal
header Headerclass Faont header
norrnal Mormalelass Fant norrnal
header Headerclass Font header

Select wariant = Select ¥ [ New presentation wariant ]

Apply | Close

You can define new presentation variants by clicking [New presentation variant] .

The properties determine the appearance of (in this case) the guestbook. The [Send] button, for
example, is shown and in the discussion overview, odd rows (#e7ebef =|:| ) differ in color from
even rows (#ffffff = |:|). Further explanation about presentations and presentation variants is
beyond the scope of this document.
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