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SUMMARY

Using the spelling check functionality, editors in GX WebManager can check text for spelling
errors. A text can standard be checked in English and Dutch. If desired, extra languages can
be added. The module offers the possibility to extend the dictionary with new words and
terms.

Within GX WebManager, spelling can be checked in the following components:

e Content elements on pages

e Content elements in Media Repository articles
e Content elements in blocks

e Newsletters

e Page models

. FAQ

e  Meetings and Papers

GX WebManager's spelling check is based on the Wintertree software and dictionary
(www.wintertree-software.com).

PREREQUISITES

Content Management
e Basic Content Management

RELATED TOPICS

Content Management
e Version control (Language switch)

VERSION CONTROL

Version ‘ Date Description

1.0 September 9, 2008 Initial version
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1 USING SPELLING CHECK

Because content can be entered in various locations within GX WebManager, it makes sense that
the editor can spell-check this content. The dictionaries used to check spelling are provided by
Wintertree (http://www.wintertree-software.com/).

In most cases the spelling check is activated with an icon from the unfolded toolbar or from the
Edit > Check spelling menu. (The toolbar can be unfolded by clicking the arrow on the
upper right). The spelling check runs through the entire page. It is not possible to spell-check a
part of the page.

File Edit Ingert Maiptain Format Configure Help My WeblManager Log out (Administrator)
|z |2 #
Zave Cherk spellng Image k.,

English *

{5 Pages

ElE]
[ content
& [ with configuration
[ eanners
[ Page section
[ ms office imports

[ Myweb - ersion: 1 of 1 | Validity: 8/5/2008- | State: Current version - Gepubliceerd -

Mavigation title: |Horme State: ‘ Gepubliceerd v‘ ‘ « Less options
Publication date: |5/5/2008 10:17  [E2  Expiration date: ==

Iv Include in search engine comment: |

When the spelling check is activated, a window pops up, displaying those words not found in the
dictionary. Possible suggestions are displayed. The use of this spelling check is very similar to the
spell checker of Microsoft products.

2 http:/fdoc-manage.gxwebmanager.com - MyWeb - Check spellin...

Mot in dictionary.: WebManager

er' editors can, within GX WebManager, check texts on Ignore
spelling errors

Ignore all

Add

anate - Change
Ermbrangle =
Wehmaster Change all

Suggestions:

Emanate

Empennage b
Language:
| English hd |
@ Done B Internet

Note for the pop-up window:

e If a word is detected that is not found in the dictionary, it will be displayed in red and
shown underneath in its context.

e ‘Language’ allows selecting the dictionary to be used.

e The [Ignore] button ensures the word will not be altered in the text.
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e The [Ignore all] button ensures that every time this word occurs (in this context), it
will be ignored. So the spelling check will not indicate again that the word is not found
in the dictionary.

e The [aAdd] button ensures that this word is added to the central dictionary on the
server. This benefits all users.

e  ‘Suggestions’ contains suggested words to replace the unknown word. If desired, select a
suggestion and then click one of the two buttons:

o [Change] changes this occurrence of the unknown word within GX WebManager
into the selected suggestion.

o [Change all] changes all occurrences of the unknown word in the current
context (page, Media Repository article, page section, newsletter, page model,

FAQ, Meetings and Papers).

After one of the buttons has been clicked, the action is processed and the spelling checker
continues its search for the next unknown word.

Also relevant:

e The first option in ‘Suggestions’ is selected by default.

e The default value of the ‘Language’ pull-down menu is derived from the language used
on the current page.

GX WebManager reports when the spelling check is finished:

2} http:{ldoc-manage.gxwebmanager.com - MyWeb - Check spellin... E'@'PZ'

Mot in dictionary. :
< Spelling check is complete, =
Suggestions:
Language:
|Eng|ish v|
&] Done #® Internet
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1.1 Adding extra dictionaries

The standard installation of GX WebManager includes the following dictionaries:

e Dutch
e UK English

It is possible to install and use extra dictionaries. These dictionaries should be purchased from
Wintertree Software and installed in GX WebManager.

GX purchases dictionaries for all clients and partners. GX distributes those dictionaries and
installs them where needed. It is not possible to add a new dictionary to GX WebManager yourself.

|
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2 CHECK SPELLING FOR EACH COMPONENT

The spelling checker will not check all the input fields of all content elements. Therefore
explanation about the usage of the check spelling will be given per component.

2.1 Content elements on pages

Running the spelling check on a page:

= Go to the relevant page.

= Click the [Check spelling] button ‘¥ on the button bar or go to the Edit > Check
spelling menu.

When the spelling check is activated, the following fields are checked:

e Title
e Navigation title (in the block with the page information)
e Introduction (from the Insert > Introduction menu)

When the spelling check is activated, the following fields in the content elements below are
checked:

e Canvas All text text in the ‘canvas’ of GX webManager
e Paragraph: Subtitle + input field

o  WYSIWYG: Subtitle + input field

e Image: Alternative text

e Table: Subtitle + content of the table cells

e Download: Name

e List: Subtitle + content of the list elements
e  Meetings and Papers: Title

e RSS feed: Subtitle

. Poll: Question + Answers

e Imagemap: Alternative text

e Calendar: Title

2.2 Content elements in Media Repository articles

To run the spelling check on a Media Repository article do as follows:

= Select in the left navigation panel the [Media Repository] tab and go to the relevant
article.

= Click the [Check spelling] button ¥ on the button bar or go to the Edit > Check

spelling menu.
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When the spelling check is activated, the following fields are checked:

e Title (in the block with the article information)
e Introduction (from the Insert > Introduction menu)
e The relevant fields of the existing content elements

2.3 Content elements in page sections

To run the spelling check on a page section do as follows:

= Select in the left navigation panel the [Page section] tab and go to the relevant block.

=  Click the [Check spelling] button :
spelling menu.

n the button bar or go to the Edit > Check

When the spelling check is activated, the following fields are checked:

o Title
e Navigation title (in the block with the block information)
e The relevant fields of the existing content elements

2.4 Newsletters

Newsletters are created on a normal webpage. The spelling can thus be checked the same way as
it is checked on a normal webpage. The related ‘Title’ and ‘Subject’ on the [Content] tab from
the Maintain > Newsletters menu can’t be checked.

2.5 FAQ

For an FAQ, not only the spelling of individual questions can be checked, but also the spelling of
an entire FAQ set.

= Select the [Questions] or [Sets] tab or the [FAQ] tab from the Maintain >
FAQs menu.

= Select the question or set that has to be checked.

= Click the [Check spelling] button
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ager.com - MyWeb - FAQs - Microsoft Internet Explorer

Maintain - FAQs
Sats Questions
Select 4 Select | Broadcasting A
Edit question 4 Selected question
Title: Eroadrasting Check spelling:
Publication 268/5/2007 E
date:
date: v
Question T've heard that all television broadcasts must be digital by 2008, True?
Ansiwer The FCC's plan for DTY implementation commenced in Movember 1993 with ~
26 "pioneer" DTY stations. 40 network DTY stations were supposed to be an air by
May 1999, with rernaining commercial and non-commercial stations by may 2003,
At this writing (03/04) there are about 1200 DTY stations broadcasting, depending
on whether you read the MAB ar FCC lists. the scheduled date for analog TV 1o "go v
4 This question is assighed to the FAQs
Digital television [pelete
4 Assign question to FAQ:
ideo equiprent
@ Done ‘ Inkernet

http:#fdoc-manage.gxwebmanager.com - MyWeb - FAQs - Microsoft Internet Explorer,

Maintain - FAQs e
Sets Questions
Select 4 Select Digital television v
Edit FAQ ¥ FAQ -
Digital televizian Cherk spelling:
} Assigned questions:
-ruadtastin!: (Published) Coelete

I've heard that all television broadcasts must be digital by 2006, True?

The FCC's plan for DTY irmplementation commenced in Novernber 1998 with 26 "pioneer” DTV stations, 40 network
DT stations were supposed to be on air by May 1999, with remaining commercial and non-commercial stations by
may 2003, At this writing (03/04) there are sbout 1200 DTY stations broadcasting, depending on whether you read
the MAR or FCC lists. the scheduled date for analog TV to "go dark" is January 1 January, 2007 - but 85% of tv homes
must have access o digital Ty before that can happen. Digital cable and satelite TV services already reached. Some
industry experts think the digital T signal might be pushed as far back as 2015! However, the FCC indicated in March
2004 that they might count digital cable T signal penetation 1o speed up the transition and stay on the ariginal
1/1/07 schedule

l ifference: (Published) Coelete

What's the difference between LCD Hat-Panel and Plasma Flat-Panel?

In all the ways that really matter, there isn't that ruch of a difference between the two, Both types of Flat-Panel TVs
arm thin ronnnh 1 be nlared vichially anveehare. and nendure & nictues that is startlinaly clrar. sharn. and_brioky

&] Done: # Internet

When the spelling check is activated, the following fields are checked:

e Title
e Question
e  Answer

|
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2.6 Page templates

To run the spelling check on a page template, do as follows:

= Select in the left navigation panel the [Page templates] tab and go to the relevant page
template.

= Click the [Check spelling] button ¥ on the button bar or go to the Edit > Check
spelling menu.

The remaining part is the same as for a normal webpage.

2.7 Meetings and Papers

To run the spelling check on metadata in a document, do as follows:

= Go to the relevant document by selecting the Maintain > Meetings and Papers
menu.

= Select the object that needs to be checked.

= Click the [Check spelling] button:

3 http:/fdoc-manage.gxwebmanager.com - MyWeb - Meetings & Papers - Microsoft Internet Explorer

@ Documents
[~ SEARCH FOR DOCUMENT
o Title: ‘Deai[\uns September 5
eetings ;
IR &ll documents Description: The plan shows how the Council is 4
[~ Date from: ‘ o | tackling the strategic issues that =
rmatter 1o e public, improving
Fapers I Document type: e and working with v
Search Check spellin
Regulati
sauistens M StalE:lGep\and V|
Title v Date v State .
Cco 1. Plans 2008 2/9/2008  Gepubliceerdyl  Publication date |02/09/2002 =B
& 2. Owervigw 2007 2/9/2008 Gepubliceet)
AT} Docurment: Browse
Document type: a
s 3 http://doc-manage.gxwebmanager.com - MyWeb - Check spellin... Institution 2
et Mot in dictionary.; Desicions District: | = Select
Desicions September 5 Ignore
URL: |
Ignore all
Add Characteristic: ‘
Suggestions Authorization: Group Level
Decluctians Burgers v | > Select |
Distirictions Change all
Evictions
Language: e
e g
& HEEN P Internet
&] pone D Internet

When the spelling check is activated, the following fields are checked:

Title
Description
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3 MAINTAINING THE CUSTUM DICTIONARY

As described in Chapter 1, it is possible to add words to the standard word list of a language when
running the spelling check. The Custom dictionary however, is the same for all languages.

The custom dictionary is viewed and changed as follows:
= Select the Edit > Custom dictionary menu.
o To add a word: enter the new word in the empty box below and click [Apply].
o To correct a word: change it and clicking [Apply].

o To delete a word: empty the field and clicking [Apply]

2 http://doc-manage.gxwebmanager.com - MyWeb - Custom dictionary - Microsoft Interne...

Custorn These wards were added to the custom dictionary by the editars.
dictionary  |\WebManager

changelog
FDF
FaQ

contentelarment
htip
XML

website

hittps

&] Done # Internet
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