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SUMMARY  

The additional ôExtended Content Managementõ package provides editors with extensive 

features for keeping the website accurate, up to date,  and complete. This component consists 

of a comprehensive web interface (preview/layout/edit), redirects, moving pages, setting 

publication and expiration dates and times, using workflow to specify who can apply which 

state changes and to which page (sets) , installing basic settings for a page (set), assigning pre -

defined presentation variants to a page (set), using list elements, and defining link models.  

 

The latest version of this document is available at  

http://www.gxdeveloperweb.com/documentation/  

 

 

PREREQUISITES  

Content Management  

 Basic Content Management  

 

 

RELATED TOPICS  

Content Management  

 News (Archives & Overviews)  

 

Presentation Services  

 Fonts & Styles  

 Layout Management  

 

Workflow & Authori zation Management  

 Workflow Management  

 Personalization Toolkit  

 

Connectivity Management  

 RSS Syndication & Aggregation 

 Portal Integration  

 

 

http://www.gxdeveloperweb.com/documentation/
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1  THE GX WEBMANAGER EDITING ENVIRONMENT  

After logging in the GX WebManager editing environment  appears showing two or three tabs:  

[ Preview] , [L ay out]  and [E dit] .  

The [Preview] tab is a backdoor for the editors to see how the page will appear on the website . 

The [Layout] tab also shows the page as it appears on the website environment but with one 

difference: texts can be modified. This tab can be disabled by the system administrator.  The 

more advanced [ Edi t]  tab is where all website content can be created and modified.  The 

various page settings and content ele ments are displayed one on top of the other  on a page: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

This is the standard editing environment for editors, application managers and developers  where 

pages are created and modified.  

 



CONTENT MANAGEMENT ð ADVANCED Content Management 

 

  e-mail info@gx.nl  http://www.gx.nl/  8/ 53  

 

 

1.1  Page information  

Above the content elements is a block containing information about the page:  

 

 

 

 

 

 

 

The fields in this area are defined as follows:  

Field  Explanation  

Navigation title  

 

The page title as it appears in navigation menus. If 

blank, the title of the page itself is used  in the 

navigation tree .  

State (*)  Manages the page status (for example ôPlannedõ, 

ôPublishedõ, and so forth) .   

More Options  

Publication date  (*)  Specifies the date  on which the page goes live  and 

will be visible to website visitors  (if the state of the 

page is ôPublishedõ).  

Expiration  date Specifies the date on which the page will no longer 

be displayed on the website.  Note:  This setting can 

be disabled for a page in the File > 

Properties > General  dialog box. If disabled, 

this field does not appear in the page block .  

Include in search engine  If the Search module has been purchased, all pages 

with this box checked will be included in searches.  

Labels This is where the summary of page labels assigned to 

this page is found.  Page labels can be assigned to 

this page by clicking  the [Adjust]  button.  Page 

labels can be created when the News (Archives & 

Overviews) license component has been purchased. 

Comment Allows you to add comments for the page. The 

comments do not appear on the public website.  

When a page contains a comment, the icon in the 

navigation for the page  contains a yellow  marking.  

 

(*) The combination of ôPublication dateõ, ôExpiration  dateõ and ôStatusõ determines whether or 

not a page is displayed on the public website.  The page will only be displayed if  the status is 

ôPublishedõ and todayõs date is between the publication date and Expiration  date.  
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While the publication date and the status must be specified, the Expiration  date may be left 

blank. If the Expiration  date is blank, the page will only be dis played if the status is ôPublishedõ 

and todayõs date is after the publication date. 

 

1.2  Delet ing content e lements  

Content elements are added to a page using the Insert menu.  A content element can be deleted 

by clicking the ôXõ in the upper right corner of the title bar (see A in the figure below ); the ôXõ 

will turn red indicating you have selected it. The next time you save the page, the element will 

be deleted.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1.3  Personal izat ion of content elements  

The personalization button   on the title bar  of  each content element can only be used if the 

ôPersonalization Toolkitõ license component from ôWorkflow & Authorization Managementõ has 

been purchased (see B in the figure above ).  Explanation of this function falls outside the scope of 

this document.  For complete information  read the document about personalization on 

http://www.gxdeveloperweb.com/Software/Documentation.htm/#GXD0019 . 

 

http://www.gxdeveloperweb.com/Software/Documentation.htm/#GXD0019
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1.4  Expanding and col lapsing content elem ents  

If there are many content elements on a page, the view of the page can sometimes become 

cluttered. It can also take time to move elements around on a page when there are many 

elements.  For the convenience of viewing pages and moving elements, it is po ssible to collapse 

and re-expand content elements  (in the same way you can minimiz e and maximize windows).  To 

do so, use the buttons on the upper right side of the title bar:  

  To collapse the content element.  

  To expand the content element .  

  To collapse all  content elements .  

  To expand all  content elements.  

 

In the example below the first image has been collapsed:  
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2  PUBLISHING A PAGE  

When a page is ready to show on the website, it can be published .  The defined  workflow  and 

authorization  settings for your website determines who is allowed  to publish or prepare a page 

for publication.  The page becomes accessible to the public as soon as it is published.  

 

Follow these steps to publish a page:  

 

 Select the page to be published  in t he navigation tree .  

 

 Set the ôStateõ to ôPublishedõ in the page information block.  The exact name of the 

published status depends on how the workflow for your website has been implemented .  

In the example below, ôGepubliceerdõ is the published state: 

 

 

 

 

 

 

 Check that the ôPublication dateõ and ôExpiration  dateõ are correct (i t is possible to set 

t he publication date in the future ).  It is not required to specify an expiration  date.  

 

Note:  To change the ôPublication dateõ and ôExpiration  dateõ, click [More op tions] .  

 

 Save the changes. 

 

The page will now be accessible to the public.  
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3  MOVING A PAGE  

Occasionally you may want to move a page to a different location in the site structure.   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

You can move pages in four  different ways :  

1. Dragging and dropping a page to a new location in the navigation tree.  

2. Moving a page using the right-click Context  menu. 

3. Moving a page using the File > Move menu. 

4. Moving a page using the page sequence list.  



CONTENT MANAGEMENT ð ADVANCED Content Management 

 

  e-mail info@gx.nl  http://www.gx.nl/  14/ 53  

 

3.1  Moving a page using drag and drop  

 

Using drag and drop you can quickly move a page to another location in the navigation tree.  You 

can use drag and drop to change the order that pages appear in the same subtree as well as move 

pages (including their subpages) to other parts of the tree. Follow these steps:  

 

 Expand the navigation tree in such a way that the page you want to move and  the 

destination where you want to move it are both visible.  This is because when you move a 

page using drag and drop, the navigation tree does not  scroll. In the example below, the 

page òImageó in the subtree òOther content elementsó will be moved to the òImagesó 

subtree.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Click the page you want to move with the left mouse button and keep the button 

depressed. 

 

 Drag the page to the part of the navigation tree where you  want to move it.  

When you drag the page through the navigation tree, you will see two different 

indicators:  

 

The page will be dropped between the two pages where the arrow is currently 

pointing.  

 

The page will be a sub-page of the page over on which the  arrow is currently 

pointing.  

 

 Release the left mouse button when the mouse pointer points to the desired location.  
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Example of moving a page between two other pages:  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Example of moving a page under another:  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note:  When you drop a page onto another page, the dropped page always occupies the bottom 

position in the subtree.  
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3.1.1  Undoing a drag and drop operation  

Drag and drop operations can be undone using the Undo feature. Note:  Only the last action can be 

undone. 

 

To undo the last drag and drop operation:  

 

 In the WebManager toolbar, click ôUndo this actionõ (beneath the text formatting 

buttons):  
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3.2  Moving pages using the Context  menu  

To move a page using the Context  menu, follow these steps:  

 

 Right-click the p age you want to move in the navigation tree and select Move from the 

Context  menu: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 A popup window will appear in which it is possible to assign a new parent page to this 

page. There are two methods to accomplish this:  

o You can type (part of) the page title into the search field and click on 

[Search] .  In this case, only those pages matching the search criteria will be 

displayed.  

o Or you can click [Show all pages] .  
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 Select the new parent page:  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Click [Apply] .  The page ôImageõ is now located below ôImagesõ: 
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3.3  Moving pages using the Fi le  menu  

The File  menu allows you to move a page to another branch on the tree.  The page can be placed 

under another page , however ,  the page order within the branch cannot be altered.  To do this, 

you need to use the ôSubsequent pagesõ list on the parent page (see ô3.4 Moving pages using the 

page sequence listõ) or you need to use the drag and drop (see ô3.1 Moving a page using drag and 

dropõ) 

 

 Select the page that has to be moved to another branch.  

 

 Go to the File > Move  menu. 

 

 A popup window will appear in w hich it is possible to assign a new parent page to this 

page. The steps hereafter are the same as described in the previous section ôMoving 

pages using the Context menuõ. 

 

 

 

3.4  Moving pages using the page sequence l is t   

If the page order has to be changed and the pages only have to be moved within the same branch 

and at the same level, this can be done on the page above it  (parent page) .  

Note:  You can also change the page sequence using drag and drop (see ô3.1 Moving a page using 

drag and dropõ).  

 

 Select the parent page and then expand the ôSubsequent pagesõ beneath the content 

elements.  The page sequence list appears.  

 

 Pages can be moved by changing their sequence numbers (under ôNumberõ) in the list :  

 

 

 

 

 

 

 

 

 Save the page.  

 

Note :  All sub pages under the page that is moved will also be moved.  In other words, the entire 

sub branch will be  moved. 
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4  USING  R EDIRECT S 

GX WebManager allows you to create two different types of re directs:  

 

 Redirect element  ñ An element placed on a web page that redirects the URL request to 

another internal page in the web initiative, an item in the Media Repository, a download, 

or an external URL.  

 Alias redirect  ñ Redirects the request for an alias URL to a  valid  URL. 

 

The major difference between the two redirect types is that the redirect element must be placed 

on an existing web page with a valid URL. When a request for the page is made, the visitor is 

directed to the requested web page from which they are then redirect ed to the desired URL. An 

alias redirect, on the other hand, redirect s a request for a n alias (non-existing) URL to another 

URL.  Alias redirects allow you to simplify and/or use more easily remembered URLs  to steer 

traffic to the  desired landing page on a website in order to increase conversion rates. Another 

benefit of a n alias redirect is that you can delete a web page from your web initiative and still 

redirect requests for it. The following two figures illustrate the difference b etween the two 

redirect  types: 
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In the example above, the alias URLs are shorter ,  more to the point ,  and easier to remember than 

the target URL to which they lead. Multiple alias URLs can point to the same target UR L. Creating 

multiple aliases that redirect to the same target URL allows you to better target users who are 

searching for a product or a service or responding to an advertising campaign. For example:  
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4.1  Inser t ing a redirect element  

A redirect element routes requests to another URL. When website visitors request the page with 

the redirect  element , they are automatically linked to the specified target.  A redirect element 

link s to the following target types:  

 Internal  ñ another page on t he web initiative  

 External  ñ a URL on an external website  

 Download  ñ a file to be downloaded  

 Media Repository  ñ an object from the Media Repository  

 Database (option)  ñ a database page 

 

To insert a redirect element, f ollow these steps:  

 

 Navigate to the page  on which the redirect is to be made.  

 

 Go to the Insert  > Redirect menu. A redirect element appear s just above the page 

title :  

 

 

 Click [+]  to expand the element.  

 

 

 

 

 Click [Search]  to specify what the redirect will link to . The link window appear s.  Note:  

the [Database]  tab only appears if the functionality ôExternal databasesõ is present 

and a database page with a detail view has been created .  See for more information 

about this the Queries document on 

http://www.gxdeveloperweb.com/Software/Documentation.htm/#GXD0082 . 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.gxdeveloperweb.com/Software/Documentation.htm/#GXD0082
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4.1.1  Redirect to an internal web page  

When visitor s navigate to  a page with an internal page  redirect, they will immediately link to the 

internal web page that is set as the target . You can choose a target page in two ways: from the 

tree or by searching for it .  

 

To set an internal page  as a target from the tree , follow these  steps: 

 

 Select the [Internal]  tab and then the [Tree]  sub tab.  

 

 Select the targ et page by navigating through the tree and click [Apply] :  

 

 

 

To set an internal page as a target using search, follow these steps:  

 

 Select the [Internal]  tab and then the [Search]  sub tab.  

 

 In the ôSearchõ box, type the name of the page or a partial string and click [Search] . 

You can also click [Show all pages]  to show all the pages of the internal web site.  

 

 Select the target page under ôAddõ and click [Apply] :  

 

 
























































